January 28, 2022
This post explains how to make a bootable USB drive for installing Linux, macOS, Windows, or... whatever else you want. From macOS. Using the command line, mostly. And unlike every other article on the internet that explains this concept on the internet, it's not blogspam, it's not filled with ads, and it's not written in broken English or with so much fluff you give up halfway through.
Follow these steps:
hdiutil convert /path/to/example.iso -format UDRW -o /path/to/example
Note that the output file implicitly gets a .dmg
extension added to the end. You'll need to include the .dmg
when you write the image to the drive.
diskutil list
This will output a big list of disks (/dev/disk1
, /dev/disk2
, /dev/disk3
, for instance). Look for the USB you just reformatted by name in the "NAME" column. Then grab the identifier from the "IDENTIFIER" column in row 0. Or just use the last string in the disk label at the start of the disk listing, a la "disk3". If you forgot to assign a meaningful name, you might be able to find it by capacity.
sudo dd if=/path/to/example.dmg of=/dev/<USB DRIVE ID> bs=1m
Note: you'll need to include the .dmg
extension at the end of your image file. If you're a little thick like me, you might forget it because you didn't include it in step 3. You do have to include it this time.
Second note: this can take a loooooong time. Like 10-20 minutes. I think mine took almost 30 minutes, and I have a pretty decently specced Macbook Pro, albeit from 2015. Seems this is pretty dependent on the image size and the quality of the storage in your USB drive, which if you're just using some random one from 10 years ago, might not be that great.